Announcement

Collapse
No announcement yet.

Sensor problem.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sensor problem.

    Hi...I seem to have a number of dust particles on the sensor ( NEX3)...I have removed these with a bulb syringe. Looking with a torch and magnifying glass I can see 3/4 small particles that seem to be behind the surface of the sensor and resist any attempt at removal. Any ideas? thanks.

  • #2
    Re: Sensor problem.

    Try with camera cleaning brushes and air blower.

    While cleaning keep in mind that you need to clean when
    >Remaining battery icon shows three marks or more.
    >Use an AC Adaptor AC-PPW20.
    >Do not use a spray blower.
    >Hold the camera face downward to prevent the dust from resettling in the camera.
    >Do not apply a mechanical shock

    Comment


    • #3
      Re: Sensor problem.

      You need to buy a dedicated sensor cleaning kit from Amazon.

      Eclipse fluid and pec pads are usually included. You can then look qt YouTube videos demonstrating the procedure.
      Basically, take test shots of white paper with a small aperture, that'll show the extent of dust particles.

      Mount the camera on a a tripod with the sensor facing downwards slightly to prevent dirt falling into it.
      Wipe only ONCE in each direction with each side of a clean pec pad. Left to right then vice versa with the other CLEAN side of the pad.

      Take another test shot and inspect the image, compare with the pre cleaning image.

      Sorry I can't be of more help as I'm not at home with my SLR equipment and cleaning kit and computer available, relying on 7" Fire tablet to post- but that's the way it's done and usually gives excellent results.

      The cleaning kits are about a tenner from Amazon. Eclipse fluid and pec pads can also be bought separately.

      Hope that helps. Maybe one if the others eg Ian, Garry Graham etc would step in if I missed anything important.

      Pol



      Originally posted by ipri View Post
      Hi...I seem to have a number of dust particles on the sensor ( NEX3)...I have removed these with a bulb syringe. Looking with a torch and magnifying glass I can see 3/4 small particles that seem to be behind the surface of the sensor and resist any attempt at removal. Any ideas? thanks.

      Comment


      • #4
        Re: Sensor problem.

        P.S ... Ipri, make sure the battery us fully charged before you start as you don't want it to close down during the procedure.

        Pol

        Comment


        • #5
          Re: Sensor problem.

          Seeing as Ipri asked this question way back in 2014 My guess is that he must have got it sorted by now. Still it's good advice for anyone else that has a similar problem.
          Regards Ron. Live each day as if it was your last. One day you will be right.

          Comment


          • #6
            Re: Sensor problem.

            Agreed! Some good advice there.

            Comment


            • #7
              Re: Sensor problem.

              Thanks Shoppy, I had been drawn in by the recent response from Selenajain and hadn't registered the date on the post from Ipri.
              Gotta get me brain better into gear

              Pol





              [QUOTE=Rodbender;86779]Seeing as Ipri asked this question way back in 2014 My guess is that he must have got it sorted by now. Still it's good advice for anyone else that has a similar problem. [/QUOTE]

              Comment


              • #8
                Re: Sensor problem.

                Was nice of you to offer such detailed good advice Pol. Never mine the date, it will surly help someone else anyway.

                Originally posted by Pol View Post
                Thanks Shoppy, I had been drawn in by the recent response from Selenajain and hadn't registered the date on the post from Ipri.
                Gotta get me brain better into gear

                Pol





                [QUOTE=Rodbender;86779]Seeing as Ipri asked this question way back in 2014 My guess is that he must have got it sorted by now. Still it's good advice for anyone else that has a similar problem.
                [/QUOTE]
                Regards Ron. Live each day as if it was your last. One day you will be right.

                Comment

                Working...
                X